Applies to:
All Design Live/Design Flex versions
Description:
While installing the Design application users may be see an error message saying that it failed to register DLLs and to Contact your support personnel.
Cause:
This behavior may occur if you try to install Design while your device has missing and/or corrupted prerequisites for the installation, such as Windows Updates, C++ and .Net Framework libraries.
Troubleshooting Steps:
Step 1 - Make sure you are connected as the local Admin.
Step 2 - Repair the .NET Framework of your device:
- Go to Start Menu > Control Panel > Programs and Features.
- At the left hand side of the screen, click on Turn Windows Features On/Off.
- Uncheck both .NET Framework boxes, click Yes if needed.
- Now check the .NET Framework 3.5 box, click Yes if needed.
- Lastly, check the .NET Framework 4.8 box, click Yes if needed.
6. You can now exit this screen.
Step 3 - Repair the C++ Redistributable:
- Go to the Start Menu > Settings ⚙ > Apps > Apps & Features.
- Scroll through the list of apps and find all instances of Microsoft C++ <version> Redistributable <x86 and x64>.
- Start with the latest version (e.g., 2019 or 2015-2019). Select it and click Modify.
- A dialog box will appear with the option to Repair the installation.
- Click Repair and wait for the process to finish.
- Repeat steps 3 to 5 for each Redistributable version you find, working backward to version 2012.
Step 4 - Reinstall Design.